Status
Welcome to the RubyGems.org status page. Here you will find real-time information about the status of our services.

Degraded service on RubyGems.org

Incident Report for RubyGems.org

Resolved

This incident has been resolved.
Posted Jul 24, 2026 - 12:06 UTC

Monitoring

We've traced the problem to one of our upstream providers and are watching closely as service recovers. Installs and pushes should be working again, though you may still see the occasional error while things settle.
Posted Jul 24, 2026 - 11:57 UTC

Identified

We're currently investigating problems across parts of RubyGems.org. Gem installs and pushes may be slow or failing, and the site itself may not load reliably.
Posted Jul 24, 2026 - 11:29 UTC
This incident affected: Application.