Status
Welcome to the RubyGems.org status page. Here you will find real-time information about the status of our services.
Degraded Performance on Dependency API
Incident Report for RubyGems.org
Resolved
The dependency API has been stable, answering all requests, for about two hours. We'll keep an eye on it, but everything seems resolved for now.
Posted about 2 years ago. Mar 22, 2016 - 22:03 UTC
Monitoring
Service has been restored. After many infrastructure, configuration, and code changes today we have found the problem. The dependency API should be returning results in a reasonable time with no errors now. We're continuing to monitor things.
Posted about 2 years ago. Mar 22, 2016 - 20:12 UTC
Investigating
We're aware of intermittent errors on the dependency api. We saw an increase in traffic yesterday and the API was having trouble responding in a timely manner. We've made several changes to the service in the last 24 hours to reduce the error rates. Our failures are down but we are still seeing some requests fail with HTTP 500 errors.

We're working to fix the remaining errors, but in the meantime you can work around this by running: `bundle install --full-index`.
Posted about 2 years ago. Mar 22, 2016 - 15:58 UTC