Status
Welcome to the RubyGems.org status page. Here you will find real-time information about the status of our services.

Gem pushes with attestation failing

Incident Report for RubyGems.org

Resolved

This incident has been resolved.
Posted Oct 27, 2025 - 21:05 UTC

Update

This issue has been resolved. Please ensure that you're using the latest version of the https://github.com/rubygems/release-gem in your Github Actions tasks.
Posted Oct 27, 2025 - 20:15 UTC

Update

We're continuing to work with the sigstore team to help resolve users being unable to gem pushes with attestations. For the time being, we recommend users update their workflows to retry gem pushes without attestations.
Posted Oct 17, 2025 - 02:15 UTC

Update

We have implemented a fix for gem pushes that use attestations on rubygems.org. However, gems that rely on the release-gem GitHub Action (https://github.com/rubygems/release-gem) to deploy to rubygems.org will still experience errors. The release-gem action will automatically retry pushing to rubygems.org without attestations, which continue to function as expected.

We are closely monitoring the situation and collaborating with the Sigstore team to resolve this issue.
Posted Oct 15, 2025 - 23:04 UTC

Identified

Gem pushes utilising the attestation feature are failing and will respond with an application error. We've identified the issue and are currently working to push a fix.
Posted Oct 15, 2025 - 06:56 UTC
This incident affected: Application.