Status
Welcome to the RubyGems.org status page. Here you will find real-time information about the status of our services.
Google Safe Browsing flag as malware
Incident Report for RubyGems.org
Resolved
Success! Google Safe Browsing has removed the malware flag from rubygems.org. Special thanks are owed to everyone who connected us to the Chrome and Safe Browsing teams, and the team members who assisted in clearing this up.
Posted May 12, 2023 - 01:01 UTC
Update
We have heard that our appeal has successfully been escalated within the Google Safe Browsing team, and they are working to resolve things.
Posted May 11, 2023 - 22:01 UTC
Identified
Google Safe Browsing has flagged the entire rubygems.org domain as malware, impacting all users of the Chrome, Safari, and Firefox browser.

The underlying issue appears to be an incorrect malware flag applied to all versions of a gem from the metasploit family. In our investigation we’ve identified that the same library is also available from GitHub and many Linux and BSD distro packages. We continue investigating, sharing information and working with Google to resolve this as soon as possible.

For the time being, there are no other issues: the website can be accessed as normal if you bypass the warning. Gem downloads and pushes continue working as normal.
Posted May 11, 2023 - 21:45 UTC
This incident affected: Application.